CentOS 下安装 Docker,要求 CentOS 系统的内核版本高于 3.10,你可以通过 uname -r 查看当前操作系统内核。

uname -r

3.10 的 Linux 内核版本与 Dockerk8s 存在兼容性问题,稳定性较差,一般推荐升级内核到 4.4 版本。

升级系统 yum 包

使用 root 权限升级 CentOS yum 包到最新,可能需要输入密码。

如无特殊说明,文内操作均以 root 用户运行。

sudo yum update -y

卸载旧版 Docker

如果系统中装过卸载旧版本(如果安装过旧版本的话)

rpm -qa | grep docker
yum remove docker docker-common docker-selinux 

安装依赖包

yum-util 提供 yum-config-manager 功能,另外两个是 devicemapper 驱动依赖。

yum install -y yum-utils device-mapper-persistent-data lvm2

添加 yum 源并更新

添加 Docker 官方和阿里云的 yum 源

yum-config-manager --add-repo https://download.docker.com/linux/centos/docker-ce.repo
yum-config-manager --add-repo http://mirrors.aliyun.com/docker-ce/linux/centos/docker-ce.repo

更新 yum 缓存,查看所有 Docker CE 版本,可以选择最新或特定版本安装。

# 清理缓存
yum clean all

# 生成新的缓存
yum makecache fast

# 查看所有社区版 Docker 安装包版本
yum list docker-ce --showduplicates | sort -r

安装 Docker

yum -y install docker-ce

启动并设置开机启动

sudo systemctl start  docker
sudo systemctl enable docker

验证安装是否成功

当执行 docker versiondocker info 时,输出内容包含 serverclient 两部分,表示 Docker 已经安装并启动成功了。

docker version
docker info
docker -h